PDA

View Full Version : Creating Wii Game Channels using WBFS for MacOSX



pande_monium
05-01-2011, 02:03 AM
Hi there,

I've just created a list of channels for all my games using the WBFS for MAC OSX utility. However, what it's done is created folders for each game with 3 files in it (eg as below)

R5IX4Q
- icon.png
- boot.dol
- meta.xml

What do I need to do with the above folders/files in order to get each channel working? Do I just dump them all onto the SD Card's root folder? Should I make a specific folder and dump them in there?

Searched Google, but couldn't find any info on how this. Please help...

I'm including a sample for ToyStoryMania here...

pande_monium
06-01-2011, 11:53 AM
Tried keeping the folders generated using WBFS for MacOSX (the 3 files as mentioned above) in the "sdcard:\apps" folder. Saw them pop up in the Homebrew Channel... but, when I ran them, I got "ERROR #002"... and the Wii asked me to eject any games and reboot the Wii...

Same thing happened when I created a ".wad" file using CustomizeMii and installed it using Wad Manager 1.5 and chose "cIOS222" or "cIOS38"... both times got the same error.

I'm using:


CustomizeMii 3.11
Legal base wads which came bundled with CustomizeMii 1.1
The "common-key.bin" file

Any ideas on what I may be doing wrong? Please help!

saffronfox
11-01-2011, 10:20 AM
what boot loader are you using?

i use uloader and have cios 38 rev 17 installed and also use wad manager 1.7.

to make the wads look for a progam called Loadstructor-1.7 with cloader and set cios 249 when making wads.

to install wads make a folder at the root of your sd and place wads in their and add wad manager to \apps\ folder of your sd, also after you have added wad manager to the apps folder check too see if the name of the app is named as boot.dol and not wad manager.dol

p.s i will upload any files you need if the mods let me but not any wads or common key as i know thats a big no no lol

pande_monium
11-01-2011, 04:03 PM
what boot loader are you using?
i use uloader and have cios 38 rev 17 installed and also use wad manager 1.7.
Not sure, but I think its cIOS 38... how can I be certain? Someplace I can check?

I use WAD Manager 1.5 and the uLoader is USBLoader (I think)... or am I confused again?


to make the wads look for a progam called Loadstructor-1.7 with cloader and set cios 249 when making wads.
Not sure what you mean here buddy... please could you elaborate a bit more. I think I used cIOS28 and cIOS222 because these were the only 2 numbered cIOS's I could find on the SDCARD/etc. So, I figured, I needed to use one of these.


to install wads make a folder at the root of your sd and place wads in their and add wad manager to \apps\ folder of your sd, also after you have added wad manager to the apps folder check too see if the name of the app is named as boot.dol and not wad manager.dol
I've got this bit all working OK - I can install WADs from the SD Card and I can see the Channels on the list... the problem arises when I try to run the channel to play the game... I think its because the WAD wasn't created correctly.

Also, I used WBFS for MAC OSX to create channels for all the games. I then put these in the \apps folder and I could see all the games pop up on the HomeBrew Channel... but again, when attempting to run the games, I got ERROR #002.

I'm thinking along the lines that I've got something installed incorrectly... or perhaps need a later version of something... maybe even start afresh and do the mod from scratch.


p.s i will upload any files you need if the mods let me but not any wads or common key as i know thats a big no no lol
I've got a few base WADs and the common key... these came with the CustomizeMii 1.1... I can PM them to you if you can check they are good...

saffronfox
12-01-2011, 12:17 AM
you dont need to mod your wii from scrach just the way you make your wads i had loads of problems when i first started making them but i did learn to make them with out the use of anysort of loader/wad making tool.

do a google sarch for something called "Loadstructor-1.7+cLoader-1.6" it is about the easyist tool out to make wads with, when you have the progam you will see what i ment about setting it too cios 249.

as for checking what cios rev. you have installed, If you use USB Loader GX it tells you in the credits screen or in configurable usb loader when you press 1 twice, also neogamma tells you at the bottom.

the 002# problem you are having could be down to the cios you are using or could me as simple as the settings in your boot loader.

if the mods dont mind i am going yo upload Loadstructor-1.7 and a few tools i have taken out the common keys.bin file and any wads i made if i am wrong to do this i am sorry. these files should help you and they have a good readme guide in.

p.s sorry if i am not explaing it very well i find if hard to explain stuf.